Le Logiciel PEB (Version 12.5)

Afin de permettre la mise en application des textes sur la Réglementation PEB qui sont d'application en Wallonie, vous trouverez sur cette page l'accès à la version 12.5 du logiciel PEB. Les anciennes versions du logiciel PEB sont également accessibles via cette page.

La version   12.5   du logiciel   ne   contient   aucune   évolution   réglementaire   puisqu'aucun changement n'est prévu prochainement dans la Réglementation PEB. Cette version reprend   donc uniquement des   nouveautés fonctionnelles   et des   résolutions d'incidents   détectés depuis la mise en ligne de la version 12.0   mais   ne contient pas de changements majeurs.   

Attention    :   Les utilisateurs de   MacOS   doivent veiller à exécuter le fichier d'installation en tant qu'Administrateur.   

La version   12.5.7 présente sur le portail de l'Energie est identique à celles   qui   sont   mises   en ligne sur les sites de Bruxelles Environnement et de la VEKA ; il n'est donc pas nécessaire de télécharger et d'installer ces différentes versions si vous souhaitez travailler dans les 3 Régions. 

MISE A JOUR AUTOMATIQUE

Cet encadré s'adresse uniquement aux utilisateurs qui n'auraient pas effectué de mise à jour récemment, et plus particulièrement vers l'une des versions 11.5.x.  

Le principe de mise à jour automatique est déjà activé pour la plupart des utilisateurs du logiciel PEB ayant déjà téléchargé la version 10.0.x. 

 

Si vous aviez   déjà installé la version 10.0   (ou   une autre   version   mise en ligne depuis)    

o    Si vous aviez   coché la case ‘Mise à jour automatique'   (choix lors de l'installation ou dans le menu ‘Configuration du logiciel'), l'application vous   proposera   automatiquement cette mise à jour   12.5, à chaque ouverture du logiciel. Vous pouvez toujours décider de l'appliquer ou de la postposer.   

o    Si vous n'aviez   pas coché la case ‘Mise à jour automatique'   (choix lors de l'installation ou dans le menu ‘Configuration du logiciel'), vous pouvez cocher cette case dans le menu ‘Configuration du logiciel' et lors de la prochaine ouverture du logiciel PEB, celui-ci vous proposera automatiquement cette mise à jour   12.5. Vous pouvez toujours décider de l'appliquer ou de la postposer.   

->   Vous ne devez pas télécharger la version   12.5   ni lancer une installation ‘classique' du logiciel PEB.   La mise à jour du logiciel PEB ‘écrasera' la version   précédente   du logiciel déjà installée sur votre ordinateur. Si vous souhaitez par la suite ouvrir un fichier avec une version précédente, vous devrez la   re-télécharger   manuellement sur notre site et ne pas appliquer la mise à jour automatique sur cette version (choix   à indiquer   lors de   la 1 e   ouverture d'une version   ou   à modifier par la suite   dans le menu ‘Configuration du logiciel').   

 

Si vous n'aviez   pas encore installé la version 10.0   (ou   une autre   version   mise en ligne depuis) :   

-> Vous devez procéder à une installation ‘classique' en téléchargeant le logiciel via le lien au bas de cette page et en exécutant le fichier téléchargé. Une fois que la version   12.5   sera   installée sur votre ordinateur, la fonction de mise à jour automatique sera active pour les prochaines versions correctives du logiciel PEB.  

 

Si   la mise à jour ne semble pas se dérouler automatiquement   alors que vous aviez coché l'option, vous pouvez consulter le document «       » pour vérifier votre connexion au serveur de mise à jour et/ou vérifier les paramètres de votre proxy si votre connexion utilise ce type de technologie.   


RAPPEL : COMPORTEMENT SPÉCIFIQUES À LA MISE À JOUR < 11.5

Ces informations s'adressent uniquement aux utilisateurs qui n'auraient pas effectué de mise à jour récemment, et plus particulièrement vers l'une des versions 11.5.x.

Si vous êtes dans le cas, nous vous renvoyons au document « PDF Liste des updates de la version 12.0 (PDF-794 ko) » qui contient un paragraphe détaillé reprenant les précautions d'usage lors de ces mises à jour.

CONVERSION OBLIGATOIRE

La conversion des fichiers entamés avec des versions précédentes (12.5.1 et antérieures) est obligatoire car la base de données PEB wallonne n'acceptera plus de fichiers provenant d'une version antérieure à partir du 1 er mai 2022 .

Sauf pour :

  • Les projets de la période « du 01/05/2010 au 31/08/2011 » souhaitant appliquer la méthode PEB 2010, qui peuvent utiliser la version 3.0.0 du logiciel PEB.

  • Les projets entamés avec la version 8.0.4 du logiciel PEB et qui, pour des raisons de corrections de bugs et d'erreurs de calcul dans cette version, peuvent décider de poursuivre leur dossier avec les versions 8.0.4 (cfr PDF News PEB 10 (PDF-689 ko) de juillet 2018).

C'est la base de données PEB qui vérifiera automatiquement, lors de votre tentative d'envoi d'un document, si la version utilisée respecte ces limitations.


Compatibilité

  • La version   12.5   peut   être utilisée pour les 3 Régions (Wallonie, Bruxelles-Capitale, Flandre) et est compatible avec toutes les versions livrées précédemment. Pour toute question relative à l'usage obligatoire   ou non   d'une version   dans les deux autres Régions, nous vous renvoyons vers les sites respectifs des deux autres   Administrations.   

  • La version   12.5   peut   être utilisée pour poursuivre et terminer les dossiers dont la demande de permis a été déposée entre le 1er mai 2010 et la date de publication de cette version   12.5, en remplacement des versions antérieures, sauf pour les cas mentionnés dans le cadre ci-dessus. Période transitoire : afin de laisser le temps aux utilisateurs de basculer vers cette nouvelle version, l'usage de la version 12.0   sera   accepté jusqu'au 30  avril 2021.  

  • La version   12.5   peut   être utilisée pour débuter des dossiers dont la demande de permis est déposée à partir du 1er janvier 2022.

Pour les raisons   évoquées ci-dessus, nous vous invitons à basculer vers la nouvelle version le plus tôt possible.  


Méthode de calcul

Aucune évolution de la méthode de calcul n'est prévue pour l'année 2022. La méthode de calcul "2021" reste donc la méthode en vigueur au 1 er   janvier 2022.  

Aucune décision n'a   en revanche   été prise concernant une éventuelle évolution réglementaire   ou non   au 1 er   janvier 2023.  


Changements majeurs de la version 12.5 (Liste des updates)

Pour aller à l'essentiel  

  • Une faille de sécurité (LOG4J-SHELL) a été détectée et rendue publique récemment. Cette vulnérabilité concerne certaines versions d'une librairie utilisée par de très nombreuses applications Java notemment. Elle peut permettre dans certains contextes une exécution de code à distance et donc une attaque. Il s'agit d'un problème global et mondial, indépendant des développements relatifs au Logiciel PEB et à la Base de données PEB.

Cette vulnérabilité est corrigée dans la version 12.5.1 (par la mise à jour de la librairie log4j vers sa version 2.17). Une mise à jour de votre version actuelle vers la version 12.5.1 vous protégera vis-à-vis de cette faille de sécurité .

Pour les utilisateurs qui souhaiteraient continuer d'utiliser des versions antérieures du Logiciel PEB, ils doivent s'assurer que ce dernier n'est pas accessible publiquement via le port 9119.

N'hésitez pas à nous contacter via notre helpdesk si vous rencontrez la moindre difficulté à ce sujet (info-peb@spw.wallonie.be) ;

  • Migration technologique du framework (Swing vers Java FX) ;

  • Ajout d'une  nouvelle période règlementaire  « A partir du 01/01/2023 » ;

  • Modifications relatives à l'encodage dont notamment la suppression des informations administratives pour l' import/export XML, l'amélioration du comportement du "Sélectionner tout" et la prise en compte d'une maçonnerie en béton cellulaire en tant qu'isolation ;

  • Correction de   bugs   ayant un impact sur les   résultats .  


Pour aller plus loin et en savoir plus sur ces changements : téléchargez le document "   PDF Liste des updates (12.0 à 12.5) (PDF-493 ko) "    


Bugfix 12.5.5

Cette version corrective a été déployée le 24/03/2022.

Parmi les incidents résolus par cette version, il y a les 2 incidents majeurs suivants :

- Incident liés aux valeurs Uf des fenêtres qui étaient automatiquement et erronément modifiées dans la version 12.5.1, utilisée depuis janvier.

Pour les fichiers ayant rencontré l'incident dans la 12.5.1 : une fenêtre particulière apparaitra lors de la conversion vers la 12.5.5, afin de « réparer » l'impact de cet incident au niveau de l'encodage. Si vous aviez déjà corrigé les valeurs erronées dans la 12.5.1 ou si celles-ci sont liées à un élément de bibliothèque, celles-ci seront automatiquement reprises ou corrigées lors de la conversion vers la 12.5.5. Le cas échéant, nous vous proposons de corriger les valeurs Uf dans la fenêtre de conversion.

- Incidents empêchant l'utilisation du Logiciel PEB sous les versions Mac Monterey :

Le problème a pu être partiellement résolu. Nous sommes en effet passé d'une situation où le logiciel PEB était inutilisable vers une situation où il sera utilisable mais malheureusement moins stable.

Les développeurs continuent leurs investigations et ont des pistes pour, nous l'espérons, résoudre complètement et durablement ces incidents.

Nous avons néanmoins décidé de mettre à votre disposition cette solution partielle afin de permettre aux utilisateurs concernés de retrouver un logiciel PEB utilisable sur leur machine.

Attention : l'origine de l'incident étant en partie lié au système de mise à jour automatique, l'installation de la 12.5.5 doit obligatoirement être manuelle pour les utilisateurs Mac Monterey. La mise à jour automatique n'est donc, pour l'instant, plus disponible.

Bugfix 12.5.7

Cette version corrective a été déployée le 17/05/2022.

Cette version contient uniquement des résolutions de bugs.


Téléchargez la version 12.5.7 du logiciel PEB

Lien vers le téléchargement


17/05/2022
24/03/2022
10/01/2022
24/12/2021
24/12/2021
09/11/2021
10/09/2021
06/05/2021
09/03/2021
07/01/2021
05/01/2021
21/10/2020
14/09/2020
20/07/2020
15/04/2020
06/02/2020
16/12/2019
30/07/2019